-- Leo's gemini proxy

-- Connecting to thrig.me:1965...

-- Connected

-- Sending request

-- Meta line: 20 text/gemini

OpenBSD 7.3


As opposed to RedHat 7.3, the OpenBSD update process is pretty trivial, and there is not a whole new operating system to learn, one that invariably breaks all your KickStart configurations and who knows what else. There are of course gotchas (like is there enough disk space to hold the upgrade sets) but I've seen worse in computing. Mostly worse.


    $ cd
    $ touch did-this-file-get-backed-up
    $ doas /usr/local/bin/rsnapshot alpha
    ...
    $ doas sysupgrade

The paranoid might physically remove the backup device; the rsnapshot scripts keep it unmounted, unless there's a backup going on. (An automated install might happily reformat the backup drive, especially if the KickStart configuration is complicated.)


    $ grep backup /etc/fstab
    /dev/sd1a /backup ffs rw,nodev,nosuid,noatime,softdep,noauto 1 2

The important thing is to take a backup right before an upgrade, in the event something goes sideways. This is better than assuming the backups are actually working, and if not you found something to fix before the upgrade. Now is also a good time to test that a new file actually got into the backups. (What, you assumed that it would? Whoops!)


After the reboots, there's some more commands,


    $ doas sysmerge
    $ doas syspatch
    $ doas pkg_add -u
    $ doas pkg_add sysclean
    $ doas sysclean > maybe-remove-these-files

and then maybe even more commands to run if you're running custom versions of things like irssi and w3m with patches for pledge and unveil. Probably I could automate this better, but I pretend to pay myself, and likewise pretend to work.


Optional Trouble I Got or Get Myself Into


If something needs dbus, it must be broken.


    $ doas chmod -x /usr/local/bin/dbus*

... and then even more commands if you have too many third-party libraries in too many old scripting languages "managed" outside of the OpenBSD package system (Rust apparently also has this problem, according to the mailing list). This is a great chance to see what dependencies you forgot about, or what isn't getting rebuilt ...


    CORRUPTION WARNING in SBCL pid 90915 pthread 0x2ca4d4730:
    Received signal 11 @ 2ca4b323c in non-lisp pthread 0x2ca4d4730, resignaling to a lisp thread.
    The integrity of this image is possibly compromised.
    Continuing with fingers crossed.
    Segmentation fault (core dumped)

... and then you may want to update /usr/src and such and compare your version of vi against any changes made in the base version of vi that yours is derived from ...


    $ ls
    SHA256          ports.tar.gz    sys.tar.gz
    SHA256.sig      src.tar.gz      xenocara.tar.gz
    $ signify -C -p /etc/signify/openbsd-73-base.pub -x SHA256.sig
    ...

Other Tests and Things to Read


Other useful tests might be to check that everything is running (usually automated with monitoring) and to send some test emails to confirm that email isn't broken (harder to automate), etc.


Of course one will want to read through the list of new features and systems, to see what might break, new system calls to check out, etc.


https://www.openbsd.org/73.html


tags #openbsd


    $ cd
    $ rm did-this-file-get-backed-up

-- Response ended

-- Page fetched on Tue May 21 09:47:05 2024